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Overview 

Javelin3 PDF readers for MacOS are fast, very small PDF readers that can open and view 
standard PDF files (.pdf) and Drumlin DRM-secured PDF files (.drmx and .drmz files). For 
advice on downloading our special DRMZ and DRMX format files, please see the 
Downloading and Catalogs sections of this document. For a more general discussion of 
offline and online PDF security, and further details and advice relating to the Javelin3 for 
Mac software, see our Wiki. 

User interface 

The screenshot below provides a sample secured PDF within the latest Javelin3 for Mac 
reader with the Outline tab area displayed. As can be seen, the Javelin3 reader is based 
on the standard Apple Mac PDF reader software "Preview". The main difference is that 
when a .drmx or .drmz file is opened it will ask for an authorization code before the 
secured PDF is displayed (on the first occasion).  

 

The menus and toolbar displayed are similar to the Mac Preview program, with the File 
menu being specific to the Javelin3 program. The items on this menu are described in the 
sections below (File menu). The toolbar includes facilities for navigation, page selection, 
searching text, view modes, zooming and downloading. These are illustrated on the 
screenshot below, with all being essentially the same as in Preview except for the 
download icon (see later in this document for more details). The toolbar can be 
customized (see the View menu item, described later in this document). 

 

https://www.drumlinsecurity.com/wiki/
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Markup and Annotation 

Markup 

Javelin3 readers support mark-up and annotation. The screenshot below illustrates this 
for a section of a document that has been selected by left-clicking the mouse and dragging 
across the text to be highlighted – this procedure can be carried out for both standard 
PDFs and secured PDFs (drmz files). After highlighting the mark-up can be removed, line-
by-line by clicking on the line in question and right-clicking to obtain the delete 
highlighting option for that line.  

 

Annotation 

A new note can be added by right-clicking on a location on a page that is not highlighted. 
Right-clicking on an existing note will enable the item to be selected so it can be amended 
or deleted. For secured PDFs annotations are stored in an external file with extension .nts 
in the same folder as the document. Text entry is via a pop-up form and when OK is 
pressed the sticky note is displayed.  
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Authorizing documents 

Online authorization 

To authorize a .drmx or .drmz file simply run Javelin3, select the File menu, Open… 
option, and pick the file to open. An authorization form is displayed the first time this 
document is viewed, as shown below: 

 

 

 

Enter the code provided to you by the document publisher (typically a 9-character string 
of text in lower case plus numbers). You can Copy the code and then use the Paste button 
to enter it into the field shown and press OK. You must have an active internet connection 
at this point because the code is checked against our server to ensure it is valid. If all is 
OK the file is opened for viewing, and the process typically does not have to be repeated 
on subsequent occasions.  

Note the DocumentID: 20835 shown on this form – each secure PDF has a unique 
DocumentID and this is used to identify the document on your Mac, even if you change the 
filename (but not the file extension). 

Once authorized a document remains accessible on the device where it has been 
authorized, but copies will not be usable if a copy is made and transferred to another 
device. In some instances (e.g. expiry of number of times a file may be viewed or printed) 
it may be possible to re-authorize a file that has "expired", generally using a new code 
provided by the publisher of the document or the same code may still be available for use 
(if multiple use of the code is permitted or the code is reset for you).  

Removal of authorization 

Occasionally it is necessary to remove authorization for a document that has previously 
been authorized. This can be achieved via the File menu, remove authorization option. 
The simplest way to use this facility is to open the document to be “un-authorized” and 
then select the file menu item. If the document is not already open Javelin3 will prompt 
for you to enter the documentID of the document in question – e.g. 20835 in the example 
shown in the previous section. Note that removal of authorization for a specific device 
does not make the authorization code available once more – ask the document publisher 
for a code reset or new code if this is required. Where a document is provided within the 
Javelin3 Catalog framework, users can right-click on the cover image and a Remove 
authorization is also provided, which provides a further convenient way of removing 
authorization, if required. 
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File menu 

Open, Open recent… 

The Open menu item enables DRMX or DRMZ files and PDF files to be opened and read. If 
a DRMX or DRMZ file is opened for the first time, the authorization process described 
above will be invoked. Once a file has been authorized it can be opened using the File 
menu, Open option, without requiring re-authorization UNLESS some feature expires (e.g., 
number of times it can be printed) and then requires re-authorization or is no longer 
available for that facility. The File menu also displays recently opened files which may be 
selected and will then be displayed. 

Properties 

The Properties menu item displays the properties for PDF files, and in addition, the DRM 
properties (permission settings) for secured PDFs (.drmx and .drmz files). An example for 
a .drmz file is shown below: 
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Save 

Saves any mark-ups or annotations that have been added prior to closing a document (on 
closing, if there are any changes the software prompts to see if you wish to save them). 

Close 

Closes the currently viewed file – note that Javelin3 for MacOS is a multi-windowing 
application so it is possible to have multiple documents open at the same time. When all 
documents are closed only the menu items are displayed, as per other Mac apps. 

Remove authorization 

Removal of authorization is a facility which is provided for two reasons. The first is to 
ensure that the stored information relating to a document and its permissions are removed 
from the Mac, in order to clear these and enable an updated version of the document to 
be re-authorized with new permission settings. This is very occasionally necessary (e.g., 
when a document version has expired), and useful when running tests before documents 
are distributed. The second reason for removal of authorization is where this is agreed 
with the publisher as a means of demonstrating that the document has been removed from 
the device in question. The removal process de-authorizes the current Mac for that 
document and also logs this on the DRM server so the publisher can confirm the action 
specified has taken place. Removal of authorization does not reset/re-enable a previously 
applied authorization code.  

Export all notes 

This facility exports any annotations (notes) as a text file and opens the result in the Mac 
TextEdit application. 

Log file 

Javelin3 creates a log of the current session which it retains in memory. This includes 
diagnostic information which we may request if you have a technical support issue. When 
selected the option displays a form as shown below – simply provide a convenient name 
for the file and it will be saved on your Mac as a text file, which you can then either open 
and copy the text into an email, or attach to an email for us to review: 

 

Check version 

When Javelin3 for Mac is run, it automatically checks to see if the software version is the 
latest available. If not, it will issue a prompt to ask if you would like to update the current 
version. There is also a menu option to enable a manual check to be carried out. The 
updated version, if available, will be available on the main Drumlin Security website via 
the Javelin downloads page. The new version can be downloaded and saved and the 
previous version can be sent to the Mac trash folder. 



Javelin3 for Apple MacOS – User Guide  

Drumlin Security Ltd  23 May 2023 Page: 7 

Page setup and Print… 

Printing from Javelin3 is very similar to printing from any other Mac application. In fact, 
it is exactly the same for PDF files, but for secured PDF files (e.g. .drmz files) printing 
may or may not be permitted. If it is not permitted or the printer is not available or of 
recognized type then a message will be displayed explaining this.  

If permission to print the document has been provided, but the permitted number of pages 
printed or times printed has been reached, a message explaining this is displayed. The 
permitted count can be reset under certain circumstances so ask the document publisher 
or service provider for assistance. For example, the OSCEhome Package document whose 
properties were illustrated earlier does permit printing. In this case a maximum number 
of 1300 pages can be printed. The document itself is shorter than this (642 pages) so the 
publisher is allowing his customers to print the document in its entirety twice. Note that 
even if printing is permitted for a secured file it is possible that printing will be prevented 
by the software. This will depend on the print device selected – for example, printing to 
a PDF or Image device is not permitted (it will result in an error message being displayed 
confirming that you cannot print to or save as a PDF). 

The print Page setup.. form is shown below as an example – note that printing from 
Javelin3 includes auto-rotate functionality, so a mixed layout document (portrait and 
landscape pages) will print correctly without having to specify the page orientation for 
some pages. 

 

Download file… 

In some instances secured PDF files (with .drmz or .drmx file extensions) will be either 
provided via an email attachment, Dropbox distribution or similar file delivery mechanism, 
or they will be placed on a website and a link for downloading provided. Alternatively 
access to files may be provided via the Catalogs… menu (if provided – see Catalogs section 
below for more details). 

An example of an internet link would be the sample test file (authorization code: 
123456789): 

https://www.drumlinsecurity.com/drmz/testfonts.drmz 

Note that when you click on a link like this you should make sure the file is downloaded 
to a permanent location on your Mac, not a temp file that is then opened. To be certain 

https://www.drumlinsecurity.com/drmz/testfonts.drmz
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of this check your Downloads folder to see if the file has been saved there or make sure 
the file is SAVE’d to your Documents folder or Desktop before trying to open it with 
Javelin3 (via the File menu, Open… option).  

If you have a problem downloading DRMX or DRMZ files from the Internet using Safari (for 
example it puts rubbish text all over your screen) we recommend that you run Javelin3, 
select the File menu, Downloads option and enter (or drag in) the web address of the file 
to download and press the Download button.  

The Download facility in Javelin3 allows you to download a drmz or drmx file direct from 
within the program, which can be much easier than using a web browser. When the 
download file menu item or toolbar icon is accessed, a form is displayed as shown below. 
You can type in the web address (URL) of the document to download, or if you have the 
address (e.g., in an email) you can drag it to the input field and then press the Download 
button to download the file. This process saves the file to your Downloads folder and asks 
if you would like to open it – if you say Yes, and the file is a PDF, it just opens, but if it is 
a drmz file then it will ask you for an authorization code. Previously downloaded files are 
shown listed in the box below the input field – these can be clicked to re-download a file 
if necessary. In general, you do not need to include the http:// or https:// bit of the web 
address as the program will recognize that the entry is a URL if it follows the basic rules 
for web addressing. 

 

Catalogs… 

The Catalog menu item displays the form shown below. This menu item is only displayed 
for recent versions of MacOS (e.g., not for pre 10.13 OSX versions). If the folder icon with 
books is clicked a set of books and further catalogs is displayed. These additional catalogs 
provide access to titles from a wide range of publishers. Alternatively, the URL (web 
address) of a publisher’s catalog can be entered in the download field shown at the top 
of this form. A catalog URL has the file extension .xml or .zip – please refer to the Catalog 
Documentation for more details 

The left arrow icon takes you back a level, the second icon allows the catalog to be 
refreshed (e.g., if new titles have been added), and the final icon is the action/download 
icon. Right-clicking on a catalog provides additional functionality: Delete catalog, Catalog 
Info, Refresh Catalog, Open catalog folder, Open catalog as text 

https://www.drumlinsecurity.com/pdf/Catalogs.pdf
https://www.drumlinsecurity.com/pdf/Catalogs.pdf
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Within a catalog, icons corresponding to documents are displayed. Clicking on an entry 
will download and save that item automatically and then prompt you for an authorization 
code if it is a drmz or drmx file. The book cover image will be displayed if the publisher 
provides one. Right clicking on an entry in a catalog displays an additional menu of items: 
Delete document, Document Info, Remove Authorization, Refresh document, Open 
document folder, Refresh document image.  
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View menu 

View/hide toolbar 

This is a simple option that enables the toolbar to be hidden in order t increase the 
available screen display area. Note that the View menu option for full screen display (see 
below) provides an extended form of this functionality. 

Customize toolbar 

The toolbar is customizable, simply by adding or removing elements using drag and drop. 
The screenshot below illustrates this, with the default toolbar shown. For example, you 
may wish to add the Print icon to the default toolbar. 

 

Full screen mode/slide view mode 

The View menu includes the option to select Full Screen mode display. This facility 
displays pages in a form suitable for projection on screens, with right and left mouse clicks 
providing forward and backward page movement. The mode can be exit-ed via the View 
menu, Toggle full screen mode, or using the Apple key sequence displayed on the menu 
item (alt+CMD+F). 

Find 

The FIND (CMD+F) option is a shortcut for simple text searches. It results in a new window 
being displayed as illustrated below: 
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Go menu 

The Go menu is provided for compatibility with the Mac program Preview, and to support 
keyboard shortcuts using the arrow and [ ] keys on a standard Mac keyboard (usually in 
conjunction with CMD or ALT keys).  

Window and Help menus 

These are the standard Mac menus for these functions. 

Accessibility and Read Aloud 

Current versions of the Javelin3 reader supports the Mac read-aloud facilities. To use this 
text-to-speech option, open a PDF or secured PDF file (typically a drmz file) and select a 
paragraph that you want to hear – press the Option key and Esc at the same time, and the 
text should be read-aloud.  

The SETTINGS app on Mac computers controls this process, and depending on the MacOS 
version you are running it might be under a heading “Dictation and Speech” or 
“Accessibility, Speech section). The Settings app defines the speed of speech, voice used, 
and key sequence that starts and stops the read-aloud facility, so please check these if 
you have any problems. 
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Additional information 

Desktop and laptop Javelin3 applications for Mac and Windows incorporate keyboard 
shortcuts for many functions. In general, these shortcuts are shown on the menu items to 
which they relate. 

Additional information relating to the Javelin3 apps can be obtained by contacting Drumlin 
Security Ltd via our main website and/or checking the many support facilities provided 
via the HELP menu on the website. This includes access to our Wiki information system:  

https://www.drumlinsecurity.com/wiki/ 

Special apps that incorporate functionality similar to Javelin3 can be developed on a 
bespoke basis. The Taxbooks app, for example, available as a free download from the 
iPAD App Store and Android App Store is a good example of this. Information regarding 
Javelin3 on other platforms is provided on our website, 

https://www.drumlinsecurity.com/  

The secured PDF files used in the Javelin3 apps are created using the free Windows-based 
software program called DrumlinPublisher, available from the Drumlin Security website. 
Standard PDF files are converted to a new file format with file extension .DRMZ – this file 
format can be read on other platforms such as iPAD, Android and Windows using Javelin3 
readers for these platforms. For more details, please see the Drumlin Security website. 
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