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Overview 

Javelin for Windows is a very fast, very small PDF reader that can open and view 
standard PDF files (.pdf) and Drumlin DRM-secured PDF files (.drmx and .drmz files). 
Note that Windows RT (an ARM version of Windows) is not supported. For details of 
Javelin PDF readers for Mac OSX computers and mobile devices such as iPADs, iPhones 
and Android tablets please see our website: 

http://www.drumlinsecurity.com/javelindownloads.html  and the relevant app stores. 

User interface 

The user interface for Javelin (JW) for is shown below. As can be seen, when a PDF or 
secured PDF (drmx or drmz file) is opened, a full range of navigation, toolbar and menu 
items are provided. Sections of this document provide details of the functionality 
provided via the menu items and toolbar icons: 

 

http://www.drumlinsecurity.com/javelindownloads.html
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Opening pdf and drmz/drmx files 

To open a standard PDF, simply use the File menu, Open… option to select and open the 
PDF for viewing, printing etc.  

To open a secured PDF (a .drmz or .drmx file) first make sure the file is saved 
somewhere permanent, e.g. your DOCUMENTS folder. Then use the Javelin File menu, 
Open… option and select the secured file to be opened. The first time you do this 
Javelin will ask you for authorization code. Enter the code you have been provided with 
by the publisher (type it in or use copy/paste) and press OK – the code will be checked 
over the internet and if OK, the file will be displayed for you. In general you only need 
to do this the first time you access the file – your PC will remember the details and the 
file can be read offline, i.e. with no internet connection required.  

Please see the authorization section for more details on authorization options. 

Navigation 

In addition to using the mouse to navigate documents, menus and icons, many features 
can be accessed using standard keyboard actions, e.g. Alt+F for the file menu, Ctrl+f for 
quick access to the Find text facility, PgUp and PgDn plus arrow keys for moving up and 
down the PDFs etc. When zoomed in, pages may be dragged up/down/left/right using 
the mouse (left mouse button, held down). Additional features are provided using right-
click on the mouse (insertion of notes/comments). 

For full details of the features in Javelin for Windows, please see the main sections 
provided in this manual. 

New features in Javelin V2 

New features in Javelin Version 2 include: 

• annotation - the ability to add notes to secure PDFs. Notes are stored separately 
from the secured PDF in a .nts file located in the same directory (folder) as the 
document itself. Notes are added using a right mouse click or via the tools menu, 
Notes option, or via the toolbar icon for notes 

• properties - a facility to provide both PDF property details and DRM properties, 
where secure PDFs are viewed 

• authorization removal - a facility (accessed via the tools menu) to allow an 
authorized document to be 'un-authorized' - useful during testing (for publishers) 
and where a publisher asks a user to remove an existing document from their PC 
(the details of this process are centrally logged) 

• enhanced zooming, with a drop-down fixed zoom facility plus a marquee zoom 
option (zooming to a selected region) 

• downloading - a built-in file downloader, enabling direct downloading of secure 
files without using a separate browser. When a secured PDF (drmz or drmx file) is 
downloaded, the software automatically asks if the user wishes to open/authorize 
it 

• auto-rotation of pages when printing – documents with mixed portrait/landscape 
page layouts can be printed in a single pass with landscape pages auto-rotated to 
ensure the correct print results 
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Authorizing documents 

Online authorization 

With Javelin for Windows there are two authorization modes for online authorization of 
DRM-protected files (JavelinPro provides additional “license-based” authorization for 
registered users):  

(A) The Javelin reader is downloaded and installed, and then the secure PDF is 
downloaded and opened using Javelin. The secure PDF is a separate file of the form 
MyFile.drmx or MyFile.drmz 

(B) The secure PDF is already embedded within the Javelin reader and is called 
something like MyFile.exe 

The two cases are described below: 

(A) Javelin.exe and MyFile.drmz saved somewhere permanent, e.g. your Documents 
folder: simply run Javelin, select the File menu, Open option, and pick 
MyFile.drmz as the file to read. An authorization form is displayed the first time 
this document is viewed, as shown below: 

 

 

 

Enter the code provided to you by the document publisher (typically a 9 character 
string of text in lower case plus numbers, e.g. 123abc456). You can COPY the 
code and then use the Clipboard button to enter it into the field shown and press 
OK. You must have an active internet connection at this point because the code is 
checked against our server to ensure it is valid. If all is OK the file is opened for 
viewing, and the process typically does not have to be repeated on subsequent 
occasions. If you have also been provided with an additional file with a .dac file 
extension, the code may already be shown in the input field, so all you need to do 
is press the OK button. 

Note the DocumentID: 8020 shown on this form – each secure PDF has a unique 
DocumentID and this is used to identify the document on your PC, even if you 
change the filename (but not the file extension). If a matching .dac file is 
provided it would be of the form 8020.dac in this example, and must be located 
in the same folder as the .drmz file to which it refers. 

Once authorized a document remains accessible on the PC where it has been 
authorized, but copies will not be usable if a copy is made and transferred to 
another device. In some instances (e.g. expiry of number of times a file may be 
viewed or printed) it may be possible to re-authorize a file that has "expired", 
generally using a new code provided by the publisher of the document or the 
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same code may still be available for use (if multiple use of the code is permitted 
or the code is reset for you).  

(B) If a secured PDF file is provided as an “executable” (e.g. MyFile.exe) the 
authorization form is immediately displayed when the exe is run, but otherwise 
the process is exactly the same as above.  

Re-authorization 

Some protected PDFs may include a limit on the number of times a document is viewed, 
or the number of pages that can be printed, or the number of days the document can be 
viewed. When these ‘counters’ have been reached the document will no longer be 
available, but may be re-instated for viewing or printing by re-authorizing it with a valid 
authorization code. This can be done via the file menu, re-authorize option, or via an 
automatic prompt to re-authorize. If the option is not available, select the remove 
authorization option from the Tools menu, and then re-open the document and you will 
be asked to authorize it, which will ensure the limits are reset. 

Removal of authorization 

Once a document has been authorized for viewing the details are stored locally on the 
PC. Very occasionally it is desirable to remove these details from the PC and this can be 
done from within Javelin for Windows via the Tools menu, Remove authorization… 
option. When invoked Javelin displays a form and asks for a documentID if there is no 
currently open document – typically a number that uniquely identifies the document, 
like 123456. By default it will remove authorization for the currently open document, 
but if a secure document is not already open but has previously been authorized on this 
PC, the documentID can be entered and it will remove the details. If that document is 
required once more it can be opened but will immediately ask for a valid authorization 
code again. Note that the Remove authorization document does NOT re-enable the code 
for further use, e.g. on another computer. 

Off-line authorization 

Off-line authorization is also provided for some documents provided in exe format. In 
this case the authorization code will be provided and must be entered in a similar 
manner to the above, but there is no need for an active internet connection. For such 
files the two fields grey-ed out in the screenshot above, name and email, will be 
enabled. The name and email address used when ordering the file must be entered 
exactly as per your order IN ADDITION TO THE CODE, and then OK pressed. If the code 
and user details match the file will be authorized offline. 

No authorization required 

In addition to off-line authorize, some protected exe files can be set so that no 
authorization is required. In this case the exe file is simply run and there will be no 
prompt to authorize the file.  

Permission-based authorization 

In Javelin for Windows, permission-based authorization is not provided. However, such 
functionality is available when JavelinPro rather than Javelin is used as the reader. In a 
permission-based system authorization is carried out centrally by the publisher, based 
on details provided to the publisher from the end user (i.e. identifying the end user and 
their device details). A license file is then generated and sent to the user to place in the 
same folder as the document to which it refers, rather like a .dac file. With this 
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arrangement online authorization is not required – it is handled by the license file. This 
option is available as part of the Corporate/Pro service option. 
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File menu 

Open 

The Open menu item enables DRMX or DRMZ files and PDF files to be opened and read. If 
a DRMX or DRMZ file is opened for the first time, the authorization process described 
above will be invoked. Once a file has been authorized it can be opened using the File 
menu, Open option, without requiring re-authorization UNLESS some feature expires 
(e.g. number of times it can be printed) and then requires re-authorization or is no 
longer available for that facility. The File menu also displays recently opened files 
which may be selected and will then be displayed. 

Close 

File Close option simply closes the current file. 

Rename file as 

This option enables you to rename a drmz file to a name that is easier/better for you to 
remember. It does not change the format of the file. For example, some publishers use 
abbreviated names or ISBN numbers as their file names. You may wish to change this to 
a meaningful text name for ease of use. Changing the name of a drmz or drmx file does 
not affect it – it is the internally stored documentID that defines the file for the 
software and service. File extensions (.pdf, .drmz and .drmx) should not be amended. 

Print 

The File|Print menu item results in a print dialog form being displayed: 
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The Javelin print dialog looks very similar to the standard Windows print dialog, but has 
a number of differences:  

(i) for PDF files this dialog is always shown, but for secure PDFs it will only be shown 
if printing is permitted, otherwise an error message will be displayed. If printing 
is permitted and the allocated number of times or pages that are allowed has 
been reached, an error message will be displayed. Print counters can be reset be 
re-authorizing a file, but this will generally require a new or reset code from the 
publisher  

(ii) for secure PDFs where printing is permitted, some functions will not be available – 
for example, printing if permitted must be to physical printers, and if the copies 
option is set to greater than 1 the setting will be ignored 

(iii) an extra tab, print scaling is provided. This enables pages that are not the same 
size as the printer paper to be re-scaled proportionally or stretched, to fit. The 
default is for no scaling to occur, with other options selectable from the drop-
down menu shown in the example below: 

 

In general we recommend using the default setting, or ensuring that the source 
document is tiled if very large, to facilitate printing on standard A4/US Letter 
format paper. For complex printing tasks publishers should consider restricting 
printing (not enabling it) and offering a printed version as a separate item that 
may be ordered. 

Properties 

The properties option provides details on both the PDF properties, as created by the PDF 
file generation software, and the DRM properties of the file (e.g. number of pages 
available to be printed, expiry date etc) if it is a drmz or drmx file. Examples of both for 
the Statsref file illustrated previously are shown below: 
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Test connection 

When the test connection option is selected the form below is shown – pressing the TEST 
button checks the internet link – an example of such a test is shown in this screenshot: 

 

Connection settings 

If the test connection fails and indicates that a proxy server and/or firewall is present, 
blocking communications from Javelin, then it “may” be possible to use the Connection 
settings option (illustrated below) to enable access via the proxy server. Initially use the 
Enable proxy button to enable the various fields, and then apply settings as advised by 
your IT services department, and then re-test the connection.  
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Even if the connection can be made, it may still fail on some sites owing to the way the 
site firewall is configured. Again, IT services can enable access from the DRM service 
web address (www.drumlinsecurity.co.uk/service.asmx) which will resolve this problem. 
However, several other options are available: (i) using a laptop or mobile device DRM 
secured files can be authorized offsite (a one-time process) via an open WiFi conection 
or home internet connection, and then used in the office/whilst travelling etc as 
required; (ii) there are offline authorization options that you can ask us about (see also 
the authorization section of this user guide); (iii) there are online browser-based options 
for access from PCs and other devices, as described in our Managed Online services 
section of the main website 

Log file 

Javelin creates a log file of activities as it opens and closes documents. In the event of a 
problem, we may ask you to use this menu option to save the log file, copy its contents, 
and email them to us to help in our diagnosis of the problem you experience 

Re-authorize 

When one of a number of counter variables reaches its limit Javelin will request re-
authorization if continued use is to be provided. Examples of counter variables include: 
the number of days during which the file can be viewed; the number of times the file 
can be opened for viewing; the number of times the file can be printed; and the number 
of pages in total that can be printed. These variables can be checked via the Properties 
form for drmz and drmx files. If necessary, contact the document publisher to obtain a 
new code. Files with an explicit expiry date cannot be re-authorized. For such files it 
would be necessary to obtain a new file with a new documentID from the publisher or to 
use the Remove authorization option first, to clear the saved details from your PC, and 
then re-authorize the file. 

http://www.drumlinsecurity.co.uk/service.asmx
http://drumlinsecurity.com/online/index.html
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View menu 

The view menu enables you to select a range of features of the program that are also 
provided as toolbar icons. Javelin remembers your last setting for windowsize, zoom 
level and sidebar (ticked or not) when re-starting the program. 

Fit page, Fit width 

The first set of options specify the size of the page display within the overall program 
window - larger sizes are easier to read but may not fit within the available window.  

Zoom in 

Single step zoom into the document (font etc becomes larger) 

Zoom out 

Single step zoom out from the document (font etc becomes smaller) 

Find text 

Text search facility – enter the word or word string you wish to search for (wildcards, 
like *, are not supported) – an example is shown below: 
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Sidebar 

The outline/navigation tree for a PDF is automatically displayed in a sidebar to the left 
of the page display, if one is provided within the source PDF file. If required this can be 
hidden via the Sidebar option, or enabled (e.g. for displaying the Notes information) 
even if no outline has been provided. 

Full screen mode 

The final option shown, which is also available as a separate icon on the toolbar, is Full 
Screen Mode. This displays the PDF with no surrounding controls or menus, filling the 
entire available screen space. In full screen mode you can move forward and backwards 
in the display using the left mouse button and right mouse button. The full screen mode 
is Exit-ed using the Esc key. Full screen mode is designed for maximization of the 
available screen area for page display and for use with digital projectors, e.g. in 
teaching and training environments. 
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Tools menu 

Languages 

The Tools menu provides access to the language selection facility - available languages 
for menus and dialog boxes (not PDF content!) are listed (e.g. French, Chinese, etc) and 
switching between languages is immediate. Note that the default language used when 
Javelin is started can be specified using the -L command line option. This facility is used 
in the Javelin for Windows French and Arabic version kits that are provided on the 
Javelin downloads page. Publishers can create their own installation kits and pre-specify 
the language and even a document to load automatically, if they so wish. 

Download 

The download option on the menu or toolbar enables downloading of a PDF or secure 
PDF without using a web browser.  

To download a file directly from the internet select the download icon on the main 
screen toolbar, as shown below: 

 

You will be prompted to enter a full internet address (a URL) – you do not need to 
include http://, for example, you can try downloading the free Statistics file:  

www.drumlinsecurity.co.uk/samples/StatsRef.pdf  

Note that the URL should not contain any spaces in the name, and for some websites will 
require the correct use of upper and lower case – in the example above the website does 
not require the correct case so statsref.pdf would also be accepted. As a general rule it 
is worth making sure the URL is correctly entered or you will receive an error message. 
To be certain you can check the URL by typing it into the address bar of a browser on 
your computer first. 

Whilst downloading is in progress you will see a progress bar with the percentage of the 
file that has been downloaded. Very large files may take a while to download, 
depending on the speed of your internet connection. 

When downloading is complete you are offered the option to open the file (for PDFs) or 
for secured PDFs (drmz files) you will be prompted to enter an authorization code. You 
must have a valid code for the publication in question, and you obtain this from the 
document publisher. For example, the code might be 123456789, so touch the input 
field in order to enter the code and a keyboard will pop-up for you to enter the 

http://www.drumlinsecurity.co.uk/samples/StatsRef.pdf
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information. Press the OK button and then the code is checked on our server and if OK, 
the file will be loaded. Again please wait while this takes place as it may take a few 
seconds. The book or document is then available for you to read – you should not need 
to authorize the document again unless you delete it or you change to using another 
device, e.g. an iPAD, Android tablet, another PC or Mac for this file. 

Previous downloads are displayed in the box below the input field – clicking on one of 
these will bring it up to the input field and enable you to re-download that item 

Remove authorization 

Sometimes you may wish to remove details relating to a document authorization from 
your PC. The section above on removal of authorization explains the process.  

Mode 

Javelin for Windows has two modes of usage: Hand mode (the default mode, with the 
cursor displayed as a hand icon) which allows you to use the mouse to drag the page 
around when zoomed in, and Zoom mode. The zoom mode changes the cursor from a 
hand to a zoom icon and enabled an area of the screen to be selected and zoomed into. 
This mode is also referred to as “marquee zoom”. To return to the default mode click on 
the Hand icon on the toolbar or use the menu item to select Hand mode again. 

Note (Document annotation) 

Javelin for Windows supports annotation of documents. This feature is invoked via the 
tools menu, notes option, or from the toolbar notes icon (yellow notes icon at the right 
hand end of the toolbar) or by a right button mouse click at the location on the page 
where the note is required. This results in a note object being added to the page at the 
location selected, as shown below. Click on the black downward-facing button to open 
the note and enter a title for the note and text in the box provided. When the note is 
complete, press the tick icon to save it an update the Notes tab on the sidebar (where 
the document outline or navigation tree is displayed). You can also use the black 
upward-facing arrow to close the note box and then drag the note object on the page to 
a better location if you wish. Use the red x icon to delete a note. 

 

 

Once notes have been created they are stored in a separate file on your PC disk, called 
<filename>.nts – this file contains all the notes associated with your document and it 
must be possible to write to the file, so the document being viewed must be in a 
folder/directory with read/write access, e.g. your Documents folder or a sub-folder of 
this main folder. If you move your PDF or drmz file to a different location, or email it to 
someone else, remember to copy across the .nts file as well, and then the notes will be 
available as before.  
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In the example shown below a note has been added to a page by clicking on the notes 
icon in the toolbar (right-hand end) and saved, and appears in an extra “Notes” tab on 
the sidebar. This indicates the page number where the note is located and the note title 
– just click on an entry in this tab area to go directly to the note in question. 
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Help menu 

About 

The Help menu provides access to the About... form. This provides details relating to 
the current document, together with a link to the Drumlin website where additional 
information and help can be found. Scroll down the form window shown to view all the 
information provided. In branded versions of the reader the company branding is 
provided on this form including a link to the company website. Also note the option 
selector to enable Extra Menu Items - if ticked or un-ticked the extra items appear/are 
hidden on the File menu. More details regarding the document are now provided on the 
File menu, Properties option. 
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Toolbar 

The Javelin for Windows toolbar is shown below. The actions of most elements are 
obvious from the icons provided. Those at the leftmost end (green arrows when 
available, grey when not) are like Browser buttons for Previous page viewed (backward 
and forward selection through the history of recently displayed pages of the file). This 
differs from page selection using the familiar first page/previous page, next page/last 
page selectors and page number selector. All the facilities (except for page rotation) are 
also available on the menus. 

 

 
 

From left to right the toolbar functions are: 

• Back, Forward (previous/next for viewed pages) 

• Open file 

• Print (if permitted) 

• Page selection: first, previous, select page number, next, last 

• Search/find 

• Fit width 

• Fit page 

• Zoom in one step, zoom out one step, select zoom extent (drop-down list) 

• Marquee zoom mode (zoom to selected area) 

• Hand mode (default) – drag page around when zoomed in 

• Download a PDF or secured PDF file (without requiring a browser) 

• Rotate left, rotate right 

• Full screen mode (Esc to exit) 

• Create a note (annotation/comment) 
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Command line options 

The following comments apply to the Windows version of Javelin only. 

The Javelin for Windows install kit is provided as a convenient way of ensuring that the 
Javelin.exe file has desktop and Start menu links, and includes file association for .DRMX 
and DRMZ files (i.e. if such files are double-clicked the file is opened using Javelin). 
Currently the command line options included in the kit for the shortcut links include -R6 
and -E (see below). 

Currently a number of optional parameters can be defined: 

Filename 

-F<filename> defines a file to open when Javelin is run. Alternatively, simply 
include the filename as the first argument, e,g. “javelin.exe myfile.drmz” 

Graphics mode 

-r or -R:  

With these parameters the default rasterization algorithm is changed to use a preferred 
algorithm. For some PDF files this can result in improved display of images, especially 
when zooming in or out. The -r parameter is temporary and just applies to the currently 
launched exe, whilst -R sets the selection as the default within the Windows registry. To 
select a specific algorithm it must be assigned a value which are the same as those used 
in the main Drumlin PDF reader (settings file). Entries are thus of the form -r6 or -R10 
(6, Bresenham, is the default for the latest Javelin kit). The available values are: 

Box = 0, 
Bell = 1, 
CatmullRom = 2, 
Cosine = 3, 
CubicBSpline = 4, 
CubicConvolution = 5, 
Bresenham = 6, 
Hermite = 7, 
Lanczos3 = 8, 
Lanczos8 = 9, 
Mitchell = 10, 
Quadratic = 11, 
QuadraticBSpline = 12, 
Triangle = 13 
 

Extended menus 

-E 

This option, which is now standard in the latest Javelin for Windows kit, ensures that the 
full menu of options is displayed on the File menu (i.e. including connection options and 
log file access). For branded readers this can be enabled or disabled, as required 

Hidden menus 

 -XM 

This option hides the menu items but leaves the toolbar in place, thereby simplifying the 
screen display further and increasing the available display space. Note that the Full 
Screen mode provides even more screen display space by removing all menus and 
toolbars. 
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Print resolution 

-Pnnn 

 

this option enables the default print resolution of 300dpi to be over-ridden with the 
value nnn, typically this would be 600, but could be a lower or higher target resolution 
than 300. Example: -P600 

Language 

-l or -L:  
 

With these parameters the default language used can be set. The structure is similar to 
that described above, with the language values being: 

0 - English 
1 - Croatian 
2 - German 
3 - Spanish 
4 - French 
5 - Japanese 
6 - Chinese (traditional) 
7 - Chinese (simplified) 
8 - Arabic 
9 - Danish 
10 – Italian 
11 – Magyar (Hungarian) 

 

Note: The numbers shown above are those that should be used to set the default 
language - this differs from the order in which languages are displayed in the Tools menu 
of Javelin, as these are shown alphabetically.  

Using a simple setup program a Javelin can be distributed to end users with the 
preferred command line parameters pre-set plus a Desktop and Start menu link to the 
file. For a more sophisticated result, for example including passing the command line 
arguments, please see our Knowledgebase article: 

http://drumlinsecurity.com/wordpress/knowledgebase/can-i-make-my-own-javelin-for-
windows-installation-kits/  

 

http://drumlinsecurity.com/wordpress/knowledgebase/can-i-make-my-own-javelin-for-windows-installation-kits/
http://drumlinsecurity.com/wordpress/knowledgebase/can-i-make-my-own-javelin-for-windows-installation-kits/
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Additional information 

Additional information relating to the Javelin apps can be obtained by contacting 
Drumlin Security Ltd and/or reviewing the extensive information available on our 
website: www.drumlinsecurity.com  

Special apps that incorporate functionality similar to Javelin can be developed on a 
bespoke basis. The Taxbooks app, for example, available as a free download from the 
iPAD App Store and Android App Store is a good example of this. Information regarding 
Javelin on other platforms is provided on our website. 

The secured PDF files used in the Javelin apps are created using the free Windows-based 
software program called Drumlin, available from the Drumlin Security website. Standard 
PDF files are converted to a new file format with file extension .DRMZ – this file format 
can be read on other platforms such as iPAD, Android and Mac OSX using Javelin readers 
for these platforms. For more details please see the Drumlin Security website. 

http://www.drumlinsecurity.com/
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